Thread Tools Search this Thread
Old 11 February 2015, 05:58   #11
apshutt's Avatar
Country: UK - England
Town: Widnes
Boat name: FROG
Make: Zodiac
Length: 3m +
Engine: Outboard 6hp
Join Date: Oct 2011
Posts: 234
I have heard about this problem somewhere else too. The advice given was to inflate the tubes first to approximately 80% then before inflating the floor lift it at the sides and centre the keel. Then inflate the floor/keel again to 80%, then fully inflate the tubes and keel to full pressure. Reinflating to full pressure after 10/15 mins on the water.
Having said that I have had no problem with keel alignment on my Zodiac (I also use an electric pump similar to the Bravo) but maybe worth a try for you. Good luck.

Always FROG
apshutt is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 23:40.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.