Reply
 
Thread Tools Search this Thread
 
Old 25 June 2013, 15:04   #1
nob
Member
 
Country: UK - England
Town: helston
Boat name: wilson
Make: avon searider
Length: 4m +
Engine: merc 50hp 2stroke
Join Date: Sep 2012
Posts: 39
merc tilt n trim

hi everyone, i've nearly finished my project but my tilt/ trim is'nt working properly, the motor runs fine but it gurgles and it wont lift unless i help it by pulling the leg up at the same time as operating the switch. i've topped it up with fluid and bled it but still no joy, there does seem to be a bit of fluid on the ram so would it need a seal kit in there or is the pump shagged? any ideas would be great by the way its a '93/'94 merc 50hp 3 cyl 2 stroke, cheers in advance, nob
__________________

__________________
nob is offline   Reply With Quote
Old 26 June 2013, 19:45   #2
Member
 
Country: UK - England
Length: 3m +
Join Date: May 2013
Posts: 116
If it sounds weird its probably got air in the system..try bleeding it some more...be warned..hydrolic systems run at high pressure and if the oil/fluid hits your skin at working pressure you'll loose what ever limb or didgit the fluid penetrates...
__________________

__________________
woz72 is offline   Reply With Quote
Old 27 June 2013, 03:20   #3
Member
 
Country: UK - Wales
Town: West Wales
Make: Vipermax 5.8, SR4.7
Length: 5m +
Engine: 150 Opti, F50EFi
Join Date: Sep 2005
Posts: 6,298
Quote:
Originally Posted by woz72 View Post
If it sounds weird its probably got air in the system..try bleeding it some more...be warned..hydrolic systems run at high pressure and if the oil/fluid hits your skin at working pressure you'll loose what ever limb or didgit the fluid penetrates...
Really?
__________________
Downhilldai is offline   Reply With Quote
Old 27 June 2013, 04:10   #4
Member
 
Country: UK - Scotland
Boat name: Wildheart
Make: Humber/Delta Seasafe
Length: 5m +
Engine: Merc 60 Clamshell
MMSI: 235068449
Join Date: Apr 2007
Posts: 4,610
I think he's saying "mind the jet".....


Yeah, I too rebuilt one. Does it also creep down if you sit on the leg when it's up? It took me something like a weeks worth of evenings to do the whole "trim up - trm down - add fluid- repeat" cycle & fully purge the air. Every night I added less & less fluid until it finally behaved itself.

You might be surprised just how frothed that stuff gets if there is air in the system.



If you can't get more fluid in & it still does this three thoughts in my head are:

- Have you tightened the manual release valve enough? - I was amazed just how tioght in mine needed to be. (and if you have replaced it have you used fluid compatible O- rings? - "standard off the shelf" O-rings will go brittle in a matter of hours on contact with the oil)

- Is there dirt in the system?

- Have you put the pressure relief valve back together the right way round? (don't ask me how I know that's possible.... )
__________________
9D280 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:18.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.