Reply
 
Thread Tools Search this Thread
 
Old 01 October 2013, 17:11   #1
Member
 
SteveHall's Avatar
 
Country: UK - England
Town: Lancs
Boat name: Beretta
Make: Ballistic
Length: 6m +
Engine: 175hp e-tec
MMSI: 235035778
Join Date: Apr 2004
Posts: 1,719
RIBase
etec poppet valve

anyone got any photos or guides on replacing / cleaning a 175 etec poppet valve?

at slow speeds / idle i get an over heat, and from reading information on the net i am guessing this could be my problem.
__________________

__________________
Steve
Member of S.A.B.S. (Lancashire Division)
https://www.justgiving.com/blind-sailing
https://www.facebook.com/rib.beretta/
SteveHall is offline   Reply With Quote
Old 01 October 2013, 17:20   #2
Member
 
kerny's Avatar
 
Country: UK - England
Town: Ashton-under-Lyne Lancs
Boat name: IMOGEN
Make: Air-Craft 5.4
Length: 5m +
Engine: Etec 60
MMSI: 235087492
Join Date: May 2010
Posts: 7,040
RIBase
Send a message via Skype™ to kerny
Quote:
Originally Posted by SteveHall View Post
anyone got any photos or guides on replacing / cleaning a 175 etec poppet valve?

at slow speeds / idle i get an over heat, and from reading information on the net i am guessing this could be my problem.
hadd had the same problem with his 130. Not sure if he got it sorted.
__________________

__________________
Member of S.A.B.S. (Lancashire Division)
kerny is offline   Reply With Quote
Old 01 October 2013, 17:21   #3
Member
 
SteveHall's Avatar
 
Country: UK - England
Town: Lancs
Boat name: Beretta
Make: Ballistic
Length: 6m +
Engine: 175hp e-tec
MMSI: 235035778
Join Date: Apr 2004
Posts: 1,719
RIBase
Ta, I will drop him a PM - I am going to start with an impeller and stats and see how it goes.
__________________
Steve
Member of S.A.B.S. (Lancashire Division)
https://www.justgiving.com/blind-sailing
https://www.facebook.com/rib.beretta/
SteveHall is offline   Reply With Quote
Old 01 October 2013, 17:35   #4
RIBnet supporter
 
Pikey Dave's Avatar
 
Country: UK - England
Town: South Yorks
Boat name: Black Pig
Make: Ribcraft
Length: 5m +
Engine: DF140a
MMSI: 235111389
Join Date: Feb 2008
Posts: 7,596
RIBase
Quote:
Originally Posted by SteveHall View Post
anyone got any photos or guides on replacing / cleaning a 175 etec poppet valve?

at slow speeds / idle i get an over heat, and from reading information on the net i am guessing this could be my problem.
Steve, I'm assuming you mean the pressure relief valve when you refer to the "poppet" valve, a faulty PR valve causes high speed overheats or low speed overcooling, it only opens at around 2500rpm. Low speed overheats are usually impeller or t/stats sticking or blocked. Easy enough to get the thermostats out to check 'em. I'll dig out the relevant pages tomorrow & post them up for you. Have you got a water pressure sensor installed?
__________________
Rule#2: Never argue with an idiot. He'll drag you down to his level & then beat you with experience.
Rule#3: Tha' can't educate pork.
Rule#4: See rule#5
Pikey Dave is offline   Reply With Quote
Old 01 October 2013, 17:40   #5
Member
 
SteveHall's Avatar
 
Country: UK - England
Town: Lancs
Boat name: Beretta
Make: Ballistic
Length: 6m +
Engine: 175hp e-tec
MMSI: 235035778
Join Date: Apr 2004
Posts: 1,719
RIBase
Dave, I am not sure what I mean... I was going to do stats and impeller but I have been reading the etec owners forum, and people talk about the same slow speed over heats as me, and say the 'poppet' valve caused this problem?
__________________
Steve
Member of S.A.B.S. (Lancashire Division)
https://www.justgiving.com/blind-sailing
https://www.facebook.com/rib.beretta/
SteveHall is offline   Reply With Quote
Old 01 October 2013, 17:45   #6
RIBnet supporter
 
Pikey Dave's Avatar
 
Country: UK - England
Town: South Yorks
Boat name: Black Pig
Make: Ribcraft
Length: 5m +
Engine: DF140a
MMSI: 235111389
Join Date: Feb 2008
Posts: 7,596
RIBase
Quote:
Originally Posted by SteveHall View Post
Dave, I am not sure what I mean... I was going to do stats and impeller but I have been reading the etec owners forum, and people talk about the same slow speed over heats as me, and say the 'poppet' valve caused this problem?
Hmm! new one on me, I'll have to dig deeper
__________________
Rule#2: Never argue with an idiot. He'll drag you down to his level & then beat you with experience.
Rule#3: Tha' can't educate pork.
Rule#4: See rule#5
Pikey Dave is offline   Reply With Quote
Old 02 October 2013, 04:57   #7
RIBnet supporter
 
Pikey Dave's Avatar
 
Country: UK - England
Town: South Yorks
Boat name: Black Pig
Make: Ribcraft
Length: 5m +
Engine: DF140a
MMSI: 235111389
Join Date: Feb 2008
Posts: 7,596
RIBase
Quote:
Originally Posted by Pikey Dave View Post
Hmm! new one on me, I'll have to dig deeper
Steve, can't find any mention of a "poppet" valve anywhere in the manual. The only relevant components of the cooling system are pump/stats/pressure relief valve. What year is yours?

Can you post a link to the posts on the Etec forum that refer to the poppet.

PS, just had a browse around the Etec forum & they are referring to the Pressure relief valve as the poppet valve. The PR valve is associated with high speed overheats as I said, not low speed. My engines have always got hot when running around 1800rpm, it's that point where the boat is trying to plane but not quite, it's pushing the hump, usually going down the river at Whitby where the speed limit is 6Kn. Have you had the engine on the laptop to check for fault codes? There are 3 possible overheat causes, port & stbd cylinder heads & EMM. They will all throw their own fault codes.
__________________
Rule#2: Never argue with an idiot. He'll drag you down to his level & then beat you with experience.
Rule#3: Tha' can't educate pork.
Rule#4: See rule#5
Pikey Dave is offline   Reply With Quote
Old 02 October 2013, 06:44   #8
Member
 
Maximus's Avatar
 
Country: UK - England
Town: Wild West
Boat name: No Boat
Make: No Boat
Length: under 3m
Join Date: Jan 2008
Posts: 4,272
Send a message via AIM to Maximus
Quote:
Originally Posted by SteveHall View Post
Dave, I am not sure what I mean... I was going to do stats and impeller but I have been reading the etec owners forum, and people talk about the same slow speed over heats as me, and say the 'poppet' valve caused this problem?
Hadd got the same sort of problem on our 1st Scotish trip.Pretty sure it was an easy fix..cracked impellor houseing I think.If he doesn't see this,drop him a pm
__________________
A clever Man learns by his mistakes..
A Wise Man learns by other people's!

The Road to HELL ..is Paved with "Good inventions!"
Maximus is offline   Reply With Quote
Old 02 October 2013, 06:49   #9
Member
 
kerny's Avatar
 
Country: UK - England
Town: Ashton-under-Lyne Lancs
Boat name: IMOGEN
Make: Air-Craft 5.4
Length: 5m +
Engine: Etec 60
MMSI: 235087492
Join Date: May 2010
Posts: 7,040
RIBase
Send a message via Skype™ to kerny
Quote:
Originally Posted by Maximus View Post
Hadd got the same sort of problem on our 1st Scotish trip.Pretty sure it was an easy fix..cracked impellor houseing I think.If he doesn't see this,drop him a pm

Wake up man look 6 posts above you
__________________
Member of S.A.B.S. (Lancashire Division)
kerny is offline   Reply With Quote
Old 02 October 2013, 07:39   #10
Member
 
Country: UK - England
Town: Bristol
Make: Ribcraft
Length: 5m +
Engine: Yamaha
Join Date: May 2006
Posts: 4,194
I think Hadd had the same problem also!!
__________________

__________________
matt h is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:56.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.