Thread Tools Search this Thread
Old 03 November 2014, 14:31   #21
Country: USA
Town: Spokane/Seattle EBM
Boat name: Phase Away...
Make: Zodiac
Length: 4m +
Engine: Outboard
Join Date: Sep 2014
Posts: 11
Haven't heard anything yet - I surely would enjoy hearing some thoughts. Thanks.

Coug Fan is offline   Reply With Quote
Old 04 November 2014, 10:24   #22
Country: USA
Town: Oakland CA
Length: 3m +
Join Date: Feb 2005
Posts: 6,623
Lacking any other ideas, I'd say you should completely deflate the tubes, and look around the bow and transom as you pull the tube away from the hull (both above and below the rail.) If there isn't some kind of anchor point (bolts, straps, whatever), I'd say the rail is simply caught up in the channel. Maybe a bunch of soapy water to lube things up?


jyasaki is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 13:16.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.