Reply
 
Thread Tools Search this Thread
 
Old 09 July 2019, 08:14   #1
Member
 
Country: Canada
Town: Sept-Iles
Boat name: Das Boot
Make: Zodiac
Length: 4m +
Engine: 50 hp Outboard
Join Date: Jun 2019
Posts: 10
RIBase
BRAVO BTP-12 Inflator hose valve problem

Own a Zodiac Medline 1. Bought a new Bravo manometer to inflate it.
Problem is the hose came with a Halsey(?) hook-in style connector apparently permanently attached. This wonít work on my Zod, which uses the hook-in fir the valve seal BUT uses a tube adapter to inflate.
Iím new at this and may be missing something blindingly obvious to the community!
Am I missing something? Is there a trick to removing the hook-in? Is there an adapter for the adapter? Iíve tried everything that came with the pump - no joy.
Thank you for any assistance you can provide.
Dave Ross / Das Boot.
__________________

__________________
Davidfross is offline   Reply With Quote
Old 12 July 2019, 06:38   #2
Member
 
Country: Canada
Town: Sept-Iles
Boat name: Das Boot
Make: Zodiac
Length: 4m +
Engine: 50 hp Outboard
Join Date: Jun 2019
Posts: 10
RIBase
Resolution.

FYI; Turns out the BTP-12 version currently marketed has the Halkey permanently glued to the business end of the inflation hose. Zod users must cut it off and purchase a Zod connector.
__________________
Davidfross is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 15:24.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.