Reply
 
Thread Tools Search this Thread
 
Old 21 October 2010, 16:14   #1
RIBnet supporter
 
donegaldan's Avatar
 
Country: Ireland
Town: Donegal
Boat name: Deep Six
Make: Redbay Stormforce
Length: 6m +
Engine: Suzuki 140 4/stroke
Join Date: Mar 2008
Posts: 175
Send a message via Skype™ to donegaldan
Navman Tracker 5430 - Screen Gone

Sooo... a question to all the more informed than me.

My little SR 4 has killed my Navman Tracker 5430.
The unit power on, however it would appear that the screen is dead.
It lights up, and dark/black vertical lines flicker across the screen horizontally.
I probably have had the unit two years at this stage, ebay purchase.
Have cracked the unit and air'ed it out in a warm dry location, no difference.
Was able to put head unit on friends boat, so different leads & power, but alas....

AFAIK Navman is no more (now Northstar), and i am possibly outside any warranty anyway.

Any suggestions from members / Trade members on possible repair options / reliable companies to contact??
I have looked online, but wanted to see has anyone had success with this type of repair, and have any recommendations.

Have looked at the Northstar 538i as a possible replacement (will take my NT MAX card)
but considered asking about repair first.

Thanks for listening. :-)
DD
__________________
donegaldan is offline   Reply With Quote
Old 21 October 2010, 16:26   #2
RIBnet supporter
 
Pikey Dave's Avatar
 
Country: UK - England
Town: South Yorks
Boat name: Black Pig
Make: Ribcraft
Length: 5m +
Engine: DF140a
MMSI: 235111389
Join Date: Feb 2008
Posts: 7,579
RIBase
are you sure that you have a good battery & 12v at the unit. check for corroision in the connector.
__________________
Rule#2: Never argue with an idiot. He'll drag you down to his level & then beat you with experience.
Rule#3: Tha' can't educate pork.
Rule#4: See rule#5
Pikey Dave is offline   Reply With Quote
Old 22 October 2010, 06:56   #3
RIBnet supporter
 
donegaldan's Avatar
 
Country: Ireland
Town: Donegal
Boat name: Deep Six
Make: Redbay Stormforce
Length: 6m +
Engine: Suzuki 140 4/stroke
Join Date: Mar 2008
Posts: 175
Send a message via Skype™ to donegaldan
Quote:
Originally Posted by donegaldan View Post
................
Was able to put head unit on friends boat, so different leads & power, but alas.................
...

DD
Thanks Pikey,
Aye, the head unit was tried on a different boat, with different batteries and different lead into the head unit.

Thanks for the suggestion tho.
Donegaldan
__________________
donegaldan is offline   Reply With Quote
Old 22 October 2010, 07:55   #4
RIBnet admin team
 
willk's Avatar
 
Country: Ireland
Make: Redbay Boats
Length: 9m +
Engine: 370hp
Join Date: Feb 2008
Posts: 12,924
RIBase
Navman equipment is very sensitive to the noxious vapours emitted by rotting vegetation, especially grass clippings. Has your boat spent protracted periods moored on a lawn?

__________________
willk is offline   Reply With Quote
Old 22 October 2010, 09:24   #5
RIBnet supporter
 
Jizm's Avatar
 
Country: UK - England
Town: Southampton
Boat name: Hissing Sid
Make: Ross Smith Cobra
Length: 6m +
Engine: 200HP Optimax
MMSI: 235038046
Join Date: Jun 2002
Posts: 3,803
My 5500i went the same way,the northstar agent may be able to repair it.

Navico UK Ltd
Premier Way, Abbey Park, Romsey, Hampshire, SO51 9DH
ph: +44 01794 510010
fax: +44 01794 510006
web:www.navico.com
Jizm is offline   Reply With Quote
Old 22 October 2010, 11:10   #6
RIBnet supporter
 
jambo's Avatar
 
Country: UK - Scotland
Town: Girvan & Tayvallich
Boat name: Breawatch
Make: Ribcraft
Length: 5m +
Engine: Mercury 150 F/stroke
MMSI: ex directory!!
Join Date: Sep 2008
Posts: 5,785
RIBase
Hi Dan my Lowrance went the same way last year thankfully the firm that fitted it took it back worked on it and has been working fine since touch wood!! There was a thread on here last year re the same problem consensus of opinion was the salt water ingress on to the metal toch pads beneath the rubberised buttons maybe some hot water over and a waggle about may help. Serious why do you not contact who ever put it in or the agent you bought it from. Hope thier more helpful than Lowrance UK agents they would not take it but only 2 years old but would sell my a recon, b------s!!
Wish you well.
See you old friend up to the baiting again, you need to give him a rough ride next time your out in yours.

Billy
__________________
jambo
'Carpe Diem'
Member of the ebay Blue RIB cover club
Member of SABS ( Scottish West Division)
jambo is offline   Reply With Quote
Old 22 October 2010, 11:40   #7
Member
 
Country: UK - England
Town: wells
Make: Ribcraft
Length: 5m +
Engine: 115
Join Date: Nov 2009
Posts: 105
The Service Centre 01929 554503

Will fix it! very reasonable price too.
__________________
mark_j is offline   Reply With Quote
Old 23 October 2010, 13:06   #8
RIBnet supporter
 
donegaldan's Avatar
 
Country: Ireland
Town: Donegal
Boat name: Deep Six
Make: Redbay Stormforce
Length: 6m +
Engine: Suzuki 140 4/stroke
Join Date: Mar 2008
Posts: 175
Send a message via Skype™ to donegaldan
Replies

Guys,
Thanks for the couple of numbers.
I have dropped the guys i bought it from a message, nearly 2.5 years ago, maybe they will be able to do something.

If not will be giving the above numbers a call and see what can be done.

Thanks again for the numbers.
Donegaldan
__________________
donegaldan is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 23:12.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.