Reply
 
Thread Tools Search this Thread
 
Old 20 September 2013, 12:51   #1
Member
 
Anchorhandler's Avatar
 
Country: France
Town: Huisnes sur Mer
Boat name: Raufoss
Make: Avon
Length: 4m +
Engine: Mercury 50
Join Date: Sep 2010
Posts: 789
460 nav light

Not just the leisure market suffering the odd issue with LED navigation lights......

This is a 7 month old Aqua Signal 65 series port side running light! :-(. Not bad for 460 eh?

We specced our latest vessel with them, but are disappointed to say that 3 of these have failed already.l AS are happy to replace them but there is a 6 week lead time..... Not great when you are a commercial operator.

Needless to say, water ingress through the side mounted (flimsy) plastic connection box meant an early grave for this "sealed" unit.

Very poor design from what used to world leaders.

Simon

Sent from my iPhone using Rib.net
Attached Thumbnails
Click image for larger version

Name:	image-2048073006.jpg
Views:	116
Size:	62.6 KB
ID:	85672   Click image for larger version

Name:	image-2729570339.jpg
Views:	107
Size:	77.6 KB
ID:	85673   Click image for larger version

Name:	image-2079788046.jpg
Views:	116
Size:	71.2 KB
ID:	85674  
__________________

__________________
C'est pas l'homme qui prend la mer, c'est la mer qui prend l'homme....
Anchorhandler is offline   Reply With Quote
Old 20 September 2013, 13:21   #2
Member
 
martini's Avatar
 
Country: UK - Channel Islands
Town: jersey
Boat name: Martini II
Make: Arctic 28/FC470
Length: 8m +
Engine: twin 225Opti/50hp 2t
MMSI: 235067688
Join Date: Jun 2005
Posts: 3,021
Thought mine were a rip off an 90 a pop when I've had to replaced all 3 already!

Trusty old series 40 on the hard boat, just wiggle the festoon bulb and problem solved
__________________

__________________
martini is offline   Reply With Quote
Old 20 September 2013, 14:00   #3
Member
 
Anchorhandler's Avatar
 
Country: France
Town: Huisnes sur Mer
Boat name: Raufoss
Make: Avon
Length: 4m +
Engine: Mercury 50
Join Date: Sep 2010
Posts: 789
Quote:
Originally Posted by martini View Post
Thought mine were a rip off an 90 a pop when I've had to replaced all 3 already!

Trusty old series 40 on the hard boat, just wiggle the festoon bulb and problem solved
Hello sailor...:-)

Sorry Never replied to your last FB msg, been chasing my tail for the last few months trying to sort out the issues with our latest arrival.....Turkish not-so delight!

Speak soon

Simon

Sent from my iPhone using Rib.net
__________________
C'est pas l'homme qui prend la mer, c'est la mer qui prend l'homme....
Anchorhandler is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 14:04.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.