Thread Tools Search this Thread
Old 03 January 2014, 17:49   #1
Country: Australia
Town: mornington
Boat name: Tigger
Make: Humber
Length: 6m +
Engine: Suzuki 140hp
Join Date: Jan 2011
Posts: 29
Suzuki DF140

I have just got the service kit for my outboard and the Suzuki dealer advised me to overhaul my oil cooler as there has been a problem with them corroding even if the engine is always flushed with fresh water after use. The modals affected are 2002 - 2009. If you do not check the oil cooler it can results in the engine oil leaking into the cooling system.
Attached Thumbnails
Click image for larger version

Name:	IMG_0940.jpg
Views:	798
Size:	114.9 KB
ID:	88788   Click image for larger version

Name:	IMG_0942.jpg
Views:	714
Size:	145.7 KB
ID:	88789  
KJH is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:43.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.