Reply
 
Thread Tools Search this Thread
 
Old 15 June 2013, 13:15   #21
Member
 
luke1979's Avatar
 
Country: UK - Wales
Length: under 3m
Join Date: May 2012
Posts: 221
Half way up the leg
__________________

__________________
luke1979 is offline   Reply With Quote
Old 15 June 2013, 13:18   #22
RIBnet admin team
 
Nos4r2's Avatar
 
Country: UK - England
Town: The wilds of Wiltshire
Boat name: WhiteNoise/Dominator
Make: Ballistic 7.8/SR5.4
Length: 7m +
Engine: Opti 225/Yam 85
MMSI: 235090687/235055163
Join Date: Jul 2005
Posts: 12,645
RIBase
Odd, it shouldn't have caused the impeller to break up then.


Has anyone else been near it?
__________________
Need spares,consoles,consumables,hire,training or even a new boat?

Please click HERE and HERE and support our Trade Members.

Join up as a Trade member or Supporter HERE
Nos4r2 is offline   Reply With Quote
Old 15 June 2013, 13:21   #23
Member
 
luke1979's Avatar
 
Country: UK - Wales
Length: under 3m
Join Date: May 2012
Posts: 221
I Dnt think so mate I just can't understand how it's happened
__________________
luke1979 is offline   Reply With Quote
Old 15 June 2013, 13:25   #24
RIBnet admin team
 
Nos4r2's Avatar
 
Country: UK - England
Town: The wilds of Wiltshire
Boat name: WhiteNoise/Dominator
Make: Ballistic 7.8/SR5.4
Length: 7m +
Engine: Opti 225/Yam 85
MMSI: 235090687/235055163
Join Date: Jul 2005
Posts: 12,645
RIBase
You didn't pick up a carrier bag round the prop or anything?
__________________
Need spares,consoles,consumables,hire,training or even a new boat?

Please click HERE and HERE and support our Trade Members.

Join up as a Trade member or Supporter HERE
Nos4r2 is offline   Reply With Quote
Old 15 June 2013, 13:26   #25
Member
 
luke1979's Avatar
 
Country: UK - Wales
Length: under 3m
Join Date: May 2012
Posts: 221
Not far as I no mate
__________________
luke1979 is offline   Reply With Quote
Old 15 June 2013, 19:39   #26
Member
 
m chappelow's Avatar
 
Country: UK - England
Town: yorkshire
Boat name: little vicky
Make: avon ex RNLI
Length: 3m +
Engine: tohatsu
Join Date: Mar 2008
Posts: 2,310
I have known with some cheap replacement impellers where the bonding or moulding between the rubber blades & the Centre Hub/sleeve of the impeller unbond leaving the impeller hub turning with the shaft but the rubber blades not turning or pumping water
Never seen it with a nylon hub but seen it twice with a brass hub .
Just a thought ?
__________________
m chappelow is offline   Reply With Quote
Old 15 June 2013, 20:50   #27
RIBnet admin team
 
Nos4r2's Avatar
 
Country: UK - England
Town: The wilds of Wiltshire
Boat name: WhiteNoise/Dominator
Make: Ballistic 7.8/SR5.4
Length: 7m +
Engine: Opti 225/Yam 85
MMSI: 235090687/235055163
Join Date: Jul 2005
Posts: 12,645
RIBase
Yeah, i've seen it too-brass insert as well. Only ever on old Johnson/Evinrudes though.
__________________
Need spares,consoles,consumables,hire,training or even a new boat?

Please click HERE and HERE and support our Trade Members.

Join up as a Trade member or Supporter HERE
Nos4r2 is offline   Reply With Quote
Old 15 June 2013, 20:58   #28
Member
 
Country: UK - England
Length: 3m +
Join Date: May 2013
Posts: 116
Happens fairly frequently with the old jabsco impellers
__________________
woz72 is offline   Reply With Quote
Old 16 June 2013, 04:49   #29
Member
 
Country: UK - England
Town: Poole
Boat name: El Mono
Make: Ribtec 9M
Length: 9m +
Engine: Yanmar 315/Bravo III
Join Date: Aug 2012
Posts: 368
Quote:
Originally Posted by Nos4r2 View Post
Yeah, i've seen it too-brass insert as well. Only ever on old Johnson/Evinrudes though.
I had exactly this on our old 5hp Johnson 2 weeks ago! Luckily I noticed the lack of telltale as soon as we left the pontoon, so put the boat straight back alongside. The impeller hadn't been changed for at least 3-4 years (possibly more), and the rubber blades had completely separated from the brass hub.
__________________
paulbrown22 is offline   Reply With Quote
Old 16 June 2013, 05:12   #30
Member
 
bingosucks's Avatar
 
Country: UK - England
Town: Nuneaton
Boat name: gnasher
Make: sr5.4
Length: 5m +
Engine: hidea 5 yam 90
Join Date: Oct 2011
Posts: 547
i managed to pick up a 15 mariner for 400

however i had a 10 merc before this and ended up buying another engine to canabalise the parts. it cost a small fortune to have it sorted carbs setting ,coils not firing etc . by the time it was finished it was mint

if i could it again i would have scrapped the first engine as it cost around the 600 mark but i half enjoyed the learning curve
__________________

__________________
bingosucks is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:15.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.