Thread Tools Search this Thread
Old 27 June 2010, 17:04   #11
lakelandterrier's Avatar
Country: UK - England
Town: Gloucester
Boat name: Lunasea
Make: Ribcraft
Length: 5m +
Engine: Suzi 140
MMSI: 232005050
Join Date: Sep 2007
Posts: 1,003
Thanks everyone for the advice.

Went out last weekend - ran for c. 5 hours Sat & 3vhours Sun - mix of idle / low revs (in river) and c. 80% WOT - 4000 revs,18Kts with no real problems.

Engine is still ocassionally missing a beat - can hear this, but is no longer cutting out.

I think int's a sticky injector, but intend to keep running with some degerent in the mix unless anyone thinks it is really worth stripping the injector out. I'm not sure how it could be better cleaned by stripping it out.

Anyway,thanks as always for the experet advice & views.


lakelandterrier is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:35.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.