Reply
 
Thread Tools Search this Thread
 
Old 13 April 2014, 10:29   #1
Member
 
Noble95's Avatar
 
Country: UK - England
Town: Southampton/Poole
Boat name: Black Racketeer
Make: White Shark & Avon
Length: 6m +
Engine: Verado 150
Join Date: Apr 2014
Posts: 180
Broken

Engine not weeing, changed impellar and checked for blockage, any help would be appreciated
__________________

__________________
Noble95 is offline   Reply With Quote
Old 13 April 2014, 10:47   #2
Member
 
1eyedjim's Avatar
 
Country: UK - England
Town: Birmingham
Boat name: Sparrowhawk
Make: Osprey
Length: 5m +
Engine: Yamaha 90hp 2T
Join Date: Apr 2010
Posts: 215
Are the impeller veins bent round the correct way?
__________________

__________________
1eyedjim is offline   Reply With Quote
Old 13 April 2014, 10:47   #3
Member
 
Noble95's Avatar
 
Country: UK - England
Town: Southampton/Poole
Boat name: Black Racketeer
Make: White Shark & Avon
Length: 6m +
Engine: Verado 150
Join Date: Apr 2014
Posts: 180
How do I know what way it's meant to go? when taking out the old impeller it didn't look to damaged
__________________
Noble95 is offline   Reply With Quote
Old 13 April 2014, 10:52   #4
Member
 
A1an's Avatar
 
Country: UK - Scotland
Town: Fort William
Make: Humber Destroyer
Length: 5m +
Engine: Yamaha F80
Join Date: Mar 2012
Posts: 2,239
RIBase
Did you locate the impeller on the key way?
__________________
There is a place on this planet for all of Gods creatures.........right next to my tatties and gravy.
A1an is offline   Reply With Quote
Old 13 April 2014, 13:58   #5
Member
 
m chappelow's Avatar
 
Country: UK - England
Town: yorkshire
Boat name: little vicky
Make: avon ex RNLI
Length: 3m +
Engine: tohatsu
Join Date: Mar 2008
Posts: 2,310
Broken

Rubber seal / grommet that goes at the top of the water -riser pipe could be trapped missing or disloged where it locates into the powerhead.
Or as A1an says about it not slotting proper into the keyway or the woodruff key may have corroded if its not a stainless one & its slipping.
__________________
m chappelow is offline   Reply With Quote
Old 13 April 2014, 15:36   #6
Member
 
RIB-Teccie's Avatar
 
Country: UK - England
Town: Leeds
Make: Valiant 450
Length: 4m +
Engine: Yamaha 55HP
Join Date: Jan 2013
Posts: 448
Bring it round to mine, I can have a look for you.
__________________
RIB-Teccie is offline   Reply With Quote
Old 13 April 2014, 15:37   #7
Member
 
RIB-Teccie's Avatar
 
Country: UK - England
Town: Leeds
Make: Valiant 450
Length: 4m +
Engine: Yamaha 55HP
Join Date: Jan 2013
Posts: 448
Sorry, thought it was Marts engine that was down.
__________________
RIB-Teccie is offline   Reply With Quote
Old 13 April 2014, 16:21   #8
Member
 
Country: UK - Wales
Town: Here
Boat name: doggypaddle
Make: Avon 5.4 Searider
Length: 5m +
Engine: yamaha 80
Join Date: Jul 2007
Posts: 1,107
maybe just the telltale blocked.
run it up on muffs and poke a bit of wire up it and wiggle.
does it overheat?
__________________

__________________
I am usually not as green as i am cabbage looking.
doggypaddle is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:13.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.