Reply
 
Thread Tools Search this Thread
 
Old 02 June 2012, 06:22   #1
Member
 
Country: UK - England
Town: Derby
Make: Ribcraft
Length: 4m +
Engine: 50 Suzuki
Join Date: May 2012
Posts: 7
2006 Suzuki 50hp four stroke trim??

Hi all, new to the forum and in need of a little help!

Having problems with the trim and tilt on the above engine for a while now.... Started off going up and down really slow so changed the seals on the hydrolics and changed fluid.worked fine! Then started doing the same after a while..... Now it's stopped all together and can just hear the solenoid clicking.
Any help would be appricated or a full 2nd hand unit maybe?
Thanks in advance!!
__________________

__________________
Derbyian1983 is offline   Reply With Quote
Old 02 June 2012, 06:58   #2
Member
 
spartacus's Avatar
 
Country: UK - Scotland
Town: Aberdeenshire
Boat name: Sula
Make: Ribcraft 4.8m
Length: 4m +
Engine: Tohatsu 60hp + aux
MMSI: 235087213
Join Date: Jun 2007
Posts: 3,268
RIBase
Carbon bushes worn out on the motor? Had the same issue with my Twatsoo. If both solenoids are working and you hear a 'click' in the up or down position - I suggest you trace the wiring from the solenoids to the trim motor, and check the motor itself. You can bypass the solenoids and see if the motor works with live feed.
__________________

__________________
Is that with or without VAT?
spartacus is offline   Reply With Quote
Old 02 June 2012, 07:27   #3
Member
 
Country: UK - England
Town: Derby
Make: Ribcraft
Length: 4m +
Engine: 50 Suzuki
Join Date: May 2012
Posts: 7
Just stripped it down.... Bushes worn and 1 bush snapped. Spring had come off the seal and filled motor with oil. Just trying to get some parts now. Thanks again.
__________________
Derbyian1983 is offline   Reply With Quote
Old 02 June 2012, 13:09   #4
Member
 
spartacus's Avatar
 
Country: UK - Scotland
Town: Aberdeenshire
Boat name: Sula
Make: Ribcraft 4.8m
Length: 4m +
Engine: Tohatsu 60hp + aux
MMSI: 235087213
Join Date: Jun 2007
Posts: 3,268
RIBase
Glad you traced the fault.

Hopefully Suzuki do a kit. Tohatsu didn't - so I made something up myself with motorbike brushes and springs from Meccanno (120b springs) - fit like a glove! The trim motor itself was mint - so no reason to pay 200 when it can be repaired. I used Mobil ATF220 fluid to top up. Purging the system of air is a pain - and takes time.
__________________
Is that with or without VAT?
spartacus is offline   Reply With Quote
Old 02 June 2012, 18:34   #5
Member
 
Country: UK - England
Town: Derby
Make: Ribcraft
Length: 4m +
Engine: 50 Suzuki
Join Date: May 2012
Posts: 7
They don't do a kit... 2 brushes and 2 seals = 114. But if that's the problem it's worth it. It's the 1st problem since owning it from new so can't grumble at all!
__________________
Derbyian1983 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:43.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.