Reply
 
Thread Tools Search this Thread
 
Old 29 May 2023, 15:35   #1
Member
 
Country: UK - England
Town: uk
Length: 5m +
Join Date: May 2023
Posts: 1
tohatsu control box issue

Hi - we have a 90hp four stroke tohatsu and are having issue with the control box - only 20hrs run time.

Basically when we put the control box arm into neutral it is not putting the actual engine into neutral, it remains under power. In the engine we can see that the notched rotating disc does not turn sufficiently to click into the neutral position, it stops short from both forward and reverse so we're assuming it's not a stretched cable issue? We've tried adding marine lubricant incase it's just a friction issue without success. - Apologise for the non technical description but hopefully the experienced rib users can unpick what I'm asking! There's also a lot of resistant to moving the control arm, unaffected by any adjustment in the tensioning knob.

Any helpful suggestions gratefully received - thanks
__________________
wend is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




All times are GMT. The time now is 20:04.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.