Reply
 
Thread Tools Search this Thread
 
Old 19 November 2022, 22:58   #1
Member
 
Country: Australia
Town: Tasmania
Boat name: Bladerunner
Make: Stacer
Length: 5m +
Engine: Mariner 2005 75HP 2
Join Date: Nov 2022
Posts: 1
2005 Mariner 75HP 2Stroke Oil Injected Elec Start

Hey guys first time poster here. I HAVE A 4.74M stacer with a 2005 75HP Mariner 2 stroke oil injected electric start outboard. Been going great first 10 trips. Has started to have issues with starting cold, once started usually starts warm ok, but sometimes even then it can be a issue. Where it used to pretty much start straight away now it turns over for a long time, before starting if it is going to. When turning over it seems to almost kick in then stops ticking over and dies nothing, or goes to tick over and makes a horrible loud metallic clunk.
Always make sure fuel bulbs in fuel line are pumped up, choke on and a few revs to start.
I do a fair bit of trout fishing and slow idling for trolling and wondering if that may be oiling up the spark plugs, or had a similar issue with my old Tohatsu and that ended up being the coil.
What type and size / gap of spark plugs are needed for this motor? Remembering I am in Australia 😉
Any ideas/ help would be great.
Cheers from down under downunder. Tasmania
__________________

__________________
Bladerunner is offline   Reply With Quote
Old 20 November 2022, 06:19   #2
Member
 
Peter_C's Avatar
 
Country: USA
Town: NorCal
Boat name: SHARKY
Make: AB
Length: 4m +
Engine: Honda BF75
Join Date: Dec 2009
Posts: 1,665
Welcome to Rib.net

Without being hands on it can be hard to diagnose. Is it rich or lean? Does opening the throttle when trying to start hot, help or hinder it's starting? Helps mean it is too rich. If no change, lightly spray starting fluid in and see if it helps. If yes it is lean. Could just be a carb adjustment. With our current emission fuels in the USA that use a lot of ethanol we are continuously having carb problems that require cleaning the jets and emulsion tubes more often than they used too.

First thing you need to do is pull the plugs and inspect them visually.
__________________

__________________
Peter_C is offline   Reply With Quote
Old 20 November 2022, 19:29   #3
Member
 
Country: UK - England
Town: Billericay
Make: SR 5.4
Engine: Evenrude E-tec 90
Join Date: Jul 2020
Posts: 40
Try only using new fuel each time. Don't leave it standing for more than 1 month.

Carbs may be varnished up.

It does need the correct plugs.

As its oil injected then don't let it run out of fuel as it may dump a load of oil in the carbs gumming them up.
__________________
Wave Rider is offline   Reply With Quote
Reply

Tags
mariner

« Spammer | Top | - »
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




All times are GMT. The time now is 10:04.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.