Thread Tools Search this Thread
Old 10 March 2008, 15:49   #1
RIBnet supporter
MustRib's Avatar
Country: UK - England
Town: Newcastle
Boat name: Merlin
Make: RB4 Gemini 550
Length: 4m +
Engine: Tohatsu 90C
Join Date: Sep 2006
Posts: 1,029

Have cable steering on my SR4. The steering set up is only about 8 months old and not had a massive amount of cables hub wheel etc etc
I havn't used the Rib for a few months and now when I turn the wheel side to side I can hear a clicking noise inside the steering hub.
Operation of the steering doesn't seem to be affected....
clearance up inside the top of my console where its mounted is definitely tight....any thoughts?

MustRib is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:16.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.