Reply
 
Thread Tools Search this Thread
 
Old 03 May 2006, 12:30   #1
Member
 
Country: UK - England
Town: Bridport
Make: Ribtec
Length: 5m +
Engine: 125
Join Date: May 2006
Posts: 2
ribtec 585

Hi I have just bought a 2nd hand ribtec 585 with a mercury 125 red band, it is great up to 20 knots but when you push on above that it sits to the port side, i have played with the trim adjustment and trim tab, any suggestions!!!
__________________

__________________
wetnwild is offline   Reply With Quote
Old 03 May 2006, 16:36   #2
Member
 
Country: UK - England
Town: Portsmouth
Boat name: Sting
Make: Tornado 6.8
Length: 6m +
Engine: Yam 200 HPDI
Join Date: Oct 2002
Posts: 637
Send a message via MSN to Andy
How are you loaded, is everything balanced
__________________

__________________
Andy

www.badviz.com
Andy is offline   Reply With Quote
Old 03 May 2006, 16:44   #3
Member
 
Kernow Buoy's Avatar
 
Country: UK - England
Town: Cornwall
Length: no boat
Join Date: Oct 2004
Posts: 1,518
Hi wetnwild,
welcome to Ribnet
Is your engine mounted in the centre of your transom? I believe that some setups require the engine to be offset ( mine is by 2" or so ) apparently the prop torque will cause the boat to list, don't take this as gospel, someone in the know will hopefully be along shortly!
__________________
Kernow Buoy is offline   Reply With Quote
Old 03 May 2006, 16:58   #4
ADS
Member
 
Country: UK - England
Town: Dorset
Length: 4m +
Join Date: Oct 2003
Posts: 1,410
Quote:
Originally Posted by wetnwild
Hi I have just bought a 2nd hand ribtec 585 with a mercury 125 red band, it is great up to 20 knots but when you push on above that it sits to the port side, i have played with the trim adjustment and trim tab, any suggestions!!!
Before you go changing things about open the bung and check its not full of water!
PM Jimbo and CJL and see if thier engines are offset (Jimbo has a 585/115Yam, CJL a 585,/135opti)
__________________
ADS is offline   Reply With Quote
Old 03 May 2006, 17:57   #5
Now back to being Mollers!
 
Country: UK - England
Town: Arundel
Boat name: Mike Bravo 1
Make: Scorp
Length: 9m +
Engine: Yanmar 300
Join Date: Oct 2005
Posts: 652
Quote:
Originally Posted by wetnwild
Hi I have just bought a 2nd hand ribtec 585 with a mercury 125 red band, it is great up to 20 knots but when you push on above that it sits to the port side, i have played with the trim adjustment and trim tab, any suggestions!!!
Hi Wetnwild, I'm surprised that that Rib needs trim tabs. Perhaps it's had a trim problem since it was put together and they've been retro fitted as a cure, which would suggest that my Cornish cuzin might be right and the motor needs an offset which isn't there. Or it's full of water!
__________________
Alice is offline   Reply With Quote
Old 03 May 2006, 18:23   #6
CJL
Member
 
CJL's Avatar
 
Country: UK - England
Town: London
Make: Ribcrafts
Length: 5m +
Engine: 150hp/2x115hp
MMSI: 235090215
Join Date: Oct 2002
Posts: 2,115
RIBase
Send a message via Skype™ to CJL
Hi there,

Yes my engine on my 585 is off set. I'm not sure how much but its not more than 2".

Before you go drilling holes in your transom have you considered trimming the engine back out? My boat lands funny when its trimmed right in against the transom.

Also I've put my spare anchor and fuel on the opposite side of the boat to the direction of the prop to compensate.

Don't fit trim tabs or go drilling holes till your tried the simple things!!

Rememeber drilling holes in a boat is not a good idea!

Chris
__________________
www.northernexposurerescue.org.uk
A registered charity supporting events across England and Wales
Follow us on Vimeo and Facebook
CJL is offline   Reply With Quote
Old 04 May 2006, 02:51   #7
Now back to being Mollers!
 
Country: UK - England
Town: Arundel
Boat name: Mike Bravo 1
Make: Scorp
Length: 9m +
Engine: Yanmar 300
Join Date: Oct 2005
Posts: 652
Ah, misread that one, you've tried adjusting the 'trim tab' not trim tabs. Get the tape measure out and check if the engine is dead centre is prob the next thing to do.
__________________
Alice is offline   Reply With Quote
Old 08 May 2006, 04:47   #8
Member
 
Country: UK - England
Town: Bridport
Make: Ribtec
Length: 5m +
Engine: 125
Join Date: May 2006
Posts: 2
[QUOTE=wetnwild] Hi I have just bought a 2nd hand ribtec 585 with a mercury 125 red band, it is great up to 20 knots but when you push on above that it sits to the port side, i have played with the trim adjustment and trim tab, any suggestions!! Thanks for all the replys, got some hydroplanes for the leg which has sorted it out now comes on the plane quickly and sits nice and square, 40.2 knots and still pulling on sunday!!!
__________________

__________________
wetnwild is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:44.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.