Reply
 
Thread Tools Search this Thread
 
Old 26 April 2006, 05:28   #1
Member
 
Country: UK - England
Town: Havant
Boat name: Ti Ariki Nui
Make: Ribeye
Length: 6m +
Engine: Outboard
Join Date: Apr 2006
Posts: 2
Problems with Ribeye

Dear Ribbers
I have purchased two new ribs from Ribeye over the last two years and both have had fuel system related problems. Has anyone else had similar issues? What are your viewpoints on the after sales service?
__________________

__________________
Hankinsonea is offline   Reply With Quote
Old 26 April 2006, 08:10   #2
Member
 
Country: UK - England
Town: Calshot
Boat name: Swan Song
Make: LM 27
Length: 8m +
Engine: Bukh 20
MMSI: ?
Join Date: Feb 2004
Posts: 206
I haven't had problems with mine but she is an older boat(2002),however my dealings with John Wood at Ribeye on another issue were very helpful and nothing was too much trouble,in saying that i did have to chase ocean quay a lot for an answer on a service issue.
__________________

__________________
About 1.5 litres per hour (slower but easier on the pocket)
Dino is offline   Reply With Quote
Old 27 July 2006, 11:45   #3
Member
 
Country: UK - England
Town: southampton
Make: ribeye
Length: 6m +
Engine: 100
Join Date: Jul 2006
Posts: 194
Ribeye 6m
After first season last year, engine kept stopping. The fuel bulb was being 'sucked in' completly and would not return to shape. Told by ribeye that the bulb should lie flat, arrow pointing horizontal. Achieved that by lengthening fuel pipe. So far it has not happened again.

Not really convinced this was the problem, it was probally a defective bulb, who knows.

Don't touch it if it still works!
__________________
ribber is offline   Reply With Quote
Old 28 July 2006, 05:53   #4
Member
 
Country: UK - England
Town: Southampton
Boat name: SMH Rib / War Shot
Make: Ribtec / Scorpion
Length: 4m +
Engine: 10hp Yam / 150hp opt
Join Date: Sep 2003
Posts: 1,894
RIBase
Quote:
Originally Posted by ribber
Ribeye 6m
After first season last year, engine kept stopping. The fuel bulb was being 'sucked in' completly and would not return to shape. Told by ribeye that the bulb should lie flat, arrow pointing horizontal. Achieved that by lengthening fuel pipe. So far it has not happened again.

Not really convinced this was the problem, it was probally a defective bulb, who knows.

Don't touch it if it still works!
If it's a "Tempo" bulb they tend to be unreliable. Make sure that it is the one supplied by the engine manufacturer.
__________________
Searider is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 18:01.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.