Thread Tools Search this Thread
Old 05 June 2012, 12:30   #1
Country: USA
Length: 3m +
Join Date: Jun 2012
Posts: 1
Mildew stains on tubes

I recently purchased an old Sea doo explorer in need of TLC. She is cleaning up well but the tubes have small black mildew stains on them. I have used a number of cleaners to try to eliminate these stains but to no avail. Any ideas would be appreciated. The tubes are very clean at this point, just these stains remain(I think there mildew). Thanks in advance!

Explorer94 is offline   Reply With Quote
Old 07 June 2012, 22:47   #2
bicyclejuju1's Avatar
Country: USA
Town: sarasota
Make: avon 310
Length: 3m +
Join Date: May 2012
Posts: 26
I used a non abrasive bathroom cleaner with bleach on an old 2001 Avon i just bought and it worked wonders. The hypalon seemed to hold up to it. Afterwards I applied a good protectant. Not sure if it was the correct thing to clean w so I'd do a test area first.
bicyclejuju1 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 20:21.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.