Reply
 
Thread Tools Search this Thread
 
Old 10 April 2011, 14:33   #1
Member
 
Country: USA
Town: Seattle
Length: 6m +
Join Date: Apr 2011
Posts: 1
forward air chamber won't inflate

I have an 18 foot Dux RIB (UD-550). It was left on the grass all winter, don't know if that affected this problem. It has six air chambers, and four valves. The aft valves just do the aft chambers. The middle port valve does both the port middle and forward chambers together. But the starboard middle valve only inflates the middle chamber, the forward chamber is completely limp. I can't find a leak. Could the internal part of the valve be damaged? When I bought it it was fully inflated. Any ideas?
__________________

__________________
dwdanby is offline   Reply With Quote
Old 10 April 2011, 19:37   #2
Member
 
Country: Other
Town: Stanley, Falkland Is
Boat name: Seawolf
Make: Osprey Vipermax 5.8
Length: 5m +
Engine: Etec 150
Join Date: Mar 2006
Posts: 3,688
Sounds like an odd arrangement but maybe a pressure relief valve is built in between the middle and forward chambers, built into the internal baffle? If so, maybe it is stuck? The inflation valves on mine can be a bit sticky if they haven't been topped up for a while.
__________________
A Boat is a hole in the water, surrounded by fibreglass, into which you throw money...

Sent from my Computer, using a keyboard and mouse
BogMonster is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 21:57.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.