Thread Tools Search this Thread
Old 26 July 2016, 05:36   #21
Country: UK - England
Town: Cornwall, UK
Make: Quicksilver 430HD
Length: 4m +
Engine: Mariner 20Hp 4s
Join Date: Jun 2016
Posts: 36

I've got that same pump as Chris. Yesterday I spent a bit of time checking out how the pressure reads on the gauge. The outcome being that connecting the pipe to the valve opens it but the gauge has a one way Valve at the pump end. This means you can check the pressure even without the pump connected.

So with a note accurate pressure set in the keel we were 5 up on a rolling choppy sea and she preformed excellently. Even when running back in with he swell the boat was more sure footed.

Cheers all, another issues' off the list

T4Syncro is offline   Reply With Quote
Old 26 July 2016, 05:55   #22
chriswood's Avatar
Join Date: Apr 2014
Posts: 92
Good to hear it's all sorted.

chriswood is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 00:53.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.