Reply
 
Thread Tools Search this Thread
 
Old 07 June 2009, 20:51   #11
Member
 
Country: UK - Wales
Town: swansea
Boat name: Too Blue
Make: BLANK
Length: 8m +
Engine: Suzuki DT225
Join Date: Mar 2004
Posts: 12,791
Remember hot weather will drastically reduce the power of a turbo charged engine unless you have an over sized intercooler.

Cold crisp days are the best - the engine breathes so much better.
__________________

__________________
codprawn is offline   Reply With Quote
Old 08 June 2009, 01:24   #12
RIBnet supporter
 
bedajim's Avatar
 
Country: UK - England
Town: Cambs/Northants
Length: no boat
Join Date: May 2006
Posts: 2,499
My Navara was like this for a couple of weeks. Dealer had it charged 450.00 for a 90000 mile service, but no change

Nissan came up with the idea it was the MAF (mass air flow sensor) and it would need a new one at 400.00
I took it out and cleaned it with some electrical circuit cleaner, taking the air filter off to get to the MAF found this black thing called the air filter element(they start off white). They had never changed it from new it now runs like a dream and I'm getting a free service

__________________
bedajim is offline   Reply With Quote
Old 08 June 2009, 02:42   #13
Member
 
Bigmuz7's Avatar
 
Country: UK - Scotland
Town: Glasgow
Boat name: stramash
Make: Tornado
Length: 5m +
Engine: Etec 90
Join Date: Feb 2006
Posts: 5,068
Quote:
Originally Posted by codprawn View Post
Remember hot weather will drastically reduce the power of a turbo charged engine unless you have an over sized intercooler.

Cold crisp days are the best - the engine breathes so much better.
Yes thats very true and did occur to me, but it was way below that. I have had the engine management light coming on intermittantly on mine, and I suspect the engine output was being restricted, but I cant find anything wrong .. oh well a trip to the dealer and more bills
__________________
Bigmuz7 is offline   Reply With Quote
Old 08 June 2009, 02:59   #14
Member
 
Country: UK - England
Town: Mighty Penryn
Boat name: Little Joe.
Make: Avon Searider
Length: 4m +
Engine: Honda BF50
Join Date: Aug 2005
Posts: 8,841
Quote:
Originally Posted by bedajim View Post
I took it out and cleaned it with some electrical circuit cleaner, taking the air filter off to get to the MAF found this black thing called the air filter element(they start off white). They had never changed it from new it now runs like a dream and I'm getting a free service
Will a free manicure be included with the service?
__________________
Mollers is offline   Reply With Quote
Old 08 June 2009, 03:03   #15
RIBnet supporter
 
bedajim's Avatar
 
Country: UK - England
Town: Cambs/Northants
Length: no boat
Join Date: May 2006
Posts: 2,499
Quote:
Originally Posted by Mollers View Post
Will a free manicure be included with the service?
That's Billy's hand I don't touch dirty tools like yourself
__________________
bedajim is offline   Reply With Quote
Old 08 June 2009, 03:17   #16
Member
 
chewy's Avatar
 
Country: UK - England
Town: Up Norf
Make: Avon SR4,Tremlett 23
Length: 4m +
Engine: Yam 55, Volvo 200
Join Date: Apr 2007
Posts: 5,217
From what I remember if you unplug the MAF the car will run better if its the MAF thats faulty.
__________________
chewy is offline   Reply With Quote
Old 08 June 2009, 11:10   #17
Administrator
 
John Kennett's Avatar
 
Country: UK - England
Town: Brighton
Length: 3m +
Join Date: May 2000
Posts: 6,829
Quote:
Originally Posted by Kernow View Post
EGR Valve stuck?
That would give those symptoms - definitely worth a check.
__________________
John Kennett is online now   Reply With Quote
Old 22 July 2009, 09:15   #18
RIBnet supporter
 
C2 RIBS's Avatar
 
Country: UK - England
Town: Hants
Boat name: Gemineye
Make: Ribeye S850 charter
Length: 8m +
Engine: 300hp
MMSI: 235097445
Join Date: Sep 2007
Posts: 3,029
Well its not the turbo, we are now investigating the Mass Air Flow as suggested, the engineers have decided this is the most likely cause and then a fuel pump issue
__________________
Ian
Rib charter and Rib hire with www.c2ribs.co.uk
C2 RIBS is offline   Reply With Quote
Old 24 July 2009, 16:26   #19
RIBnet supporter
 
C2 RIBS's Avatar
 
Country: UK - England
Town: Hants
Boat name: Gemineye
Make: Ribeye S850 charter
Length: 8m +
Engine: 300hp
MMSI: 235097445
Join Date: Sep 2007
Posts: 3,029
Finally sorted - air mass sensor replaced and now working. Thanks
__________________
Ian
Rib charter and Rib hire with www.c2ribs.co.uk
C2 RIBS is offline   Reply With Quote
Old 18 September 2009, 16:38   #20
Member
 
Bigmuz7's Avatar
 
Country: UK - Scotland
Town: Glasgow
Boat name: stramash
Make: Tornado
Length: 5m +
Engine: Etec 90
Join Date: Feb 2006
Posts: 5,068
Quote:
Originally Posted by Bigmuz7 View Post
Yes thats very true and did occur to me, but it was way below that. I have had the engine management light coming on intermittantly on mine, and I suspect the engine output was being restricted, but I cant find anything wrong .. oh well a trip to the dealer and more bills

Sorted .. a cracked Vacuum pipe .. no pipe specified, so they could be pulling my plunger for all I know
__________________

__________________
Bigmuz7 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 17:02.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.