Reply
 
Thread Tools Search this Thread
 
Old 02 March 2008, 11:48   #1
Member
 
Country: UK - England
Town: St Albans
Boat name: Skylark
Make: Ribcraft 585
Length: 5m +
Engine: 140 Suzuki
Join Date: Oct 2004
Posts: 143
New Battery no electrics!

Fitted a new battery on the boat today
Whilst the engine starts and dials are fine there is no juice going to the GPS, VHF, FF, bilge pump etc
I have connected all the leads up to the battery as per previous
The old battery went completely flat
Any clues
Cheers
__________________

__________________
Andrew Edge
The Edges is offline   Reply With Quote
Old 02 March 2008, 11:58   #2
Member
 
Pete7's Avatar
 
Country: UK - England
Town: Gosport
Boat name: April Lass
Make: Moody 31
Length: 9m +
Join Date: Aug 2001
Posts: 4,850
You have missed one, or an earth, check the fuse box wires to the battery. However there is a possibility that they have wired the accessories of the ignition wire of the engine which will require the key to be turned on. Prefer to wire from the battery personally.

Is the boat at home, you have just under an hour before it goes dark, so no pressure

Pete
__________________

__________________
.
Ribnet is best viewed on a computer of some sort
Pete7 is offline   Reply With Quote
Old 02 March 2008, 14:21   #3
Member
 
Country: UK - England
Town: St Albans
Boat name: Skylark
Make: Ribcraft 585
Length: 5m +
Engine: 140 Suzuki
Join Date: Oct 2004
Posts: 143
Quote:
Originally Posted by Pete7 View Post
You have missed one, or an earth, check the fuse box wires to the battery. However there is a possibility that they have wired the accessories of the ignition wire of the engine which will require the key to be turned on. Prefer to wire from the battery personally.

Is the boat at home, you have just under an hour before it goes dark, so no pressure

Pete
Pete
Thanks for the advice. Lost the light now so its next weekend
Thanks again
Andrew
__________________
Andrew Edge
The Edges is offline   Reply With Quote
Old 16 March 2008, 14:04   #4
Member
 
Country: UK - England
Town: St Albans
Boat name: Skylark
Make: Ribcraft 585
Length: 5m +
Engine: 140 Suzuki
Join Date: Oct 2004
Posts: 143
Quote:
Originally Posted by The Edges View Post
Pete
Thanks for the advice. Lost the light now so its next weekend
Thanks again
Andrew
Pete
It was as you suggested a missing lead to the - terminal
Thanks
Andrew
__________________
Andrew Edge
The Edges is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 20:12.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.