Thread Tools Search this Thread
Old 18 August 2009, 18:26   #1
Country: UK - England
Town: plymouth
Make: Ribtec
Length: 6m +
Engine: Mercury 175 optimax
Join Date: Feb 2008
Posts: 346
Navman not orking now, can this year get worse?!

Ok, following on from my engine packing up, now its the turn of the navman!

I have an 8120, that i I got 2nd hand.

Anyway the screen has stopped working, it lights up, like a back light but thats it! If yu press the buttons it beeps.

Can anyone recommend someone who might be able to fix this problem? probably needs a new screen!
Miller is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:35.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.