Thread Tools Search this Thread
Old 11 August 2010, 15:43   #1
RIBnet supporter
Country: UK - England
Town: South Coast
Length: 7m +
Join Date: Apr 2008
Posts: 1,443

We have a Simrad NX45 Nav station/plotter on the Parker. Yesterday morning it failed to boot up properly. I called Navico and their customer service guys talked me through some possible solutions. Unfortunately none of them worked.

The only option was to return it to them for repair as less than one year old. As this equipment is part of our coding requirements and Navico are based in Romsey, I took it there myself to save on postal time. I explained my urgency need of return.

I then borrowed a plotter from my "old" RIB as still friends with new owner.

I got a call to today to inform me that plotter repaired and that it was ready for collection.

Just wanted to give a very loud shout out for the very good service from Navico, less than 23 hours from drop off to collection.

250kts is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 20:06.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.