Reply
 
Thread Tools Search this Thread
 
Old 19 April 2011, 15:40   #1
Member
 
Country: Ireland
Town: clifden
Boat name: outbound
Make: avon 6m\ osprey 6,25
Length: 6m +
Engine: outboard suzi df140
Join Date: Sep 2009
Posts: 42
lowrance gps lms 527c df igps

looking for a bit of info, my gps wont power up after t winter, power is going in, i wonder is this a problem with lowerance, its my second one in 6 years, this current one is just 3 years, anyone got any ideas. thanks
__________________

__________________
nan-ber is offline   Reply With Quote
Old 19 April 2011, 22:09   #2
Member
 
Country: USA
Town: Oakland CA
Length: 3m +
Join Date: Feb 2005
Posts: 6,653
Had a problem similar to that, it ended up that the unit collected about a pint of water. Just out of warranty, but Lowrance replaced it anyway.

That said, it's been reported that Lowrance has had a few issues with the pushbuttons going bad. Might try mashing/twisting/rocking and see what happens.

Luck;

jky
__________________

__________________
jyasaki is offline   Reply With Quote
Old 26 April 2011, 16:18   #3
Member
 
Country: Ireland
Town: clifden
Boat name: outbound
Make: avon 6m\ osprey 6,25
Length: 6m +
Engine: outboard suzi df140
Join Date: Sep 2009
Posts: 42
same as ,opened the unit and about half a pint came outm lowerance wont do anything except sell me a new unit at a reduced cost, seeing that that s my third lowerance i m considering a garmin, any one any ideas, thanks
__________________
nan-ber is offline   Reply With Quote
Old 27 April 2011, 11:34   #4
Member
 
Country: USA
Town: Oakland CA
Length: 3m +
Join Date: Feb 2005
Posts: 6,653
Don't know. I was disappointed when my unit went down; Lowrance replaced it; no problems since. A buddy of mine has the same unit, and his has been fault-free as well.

Might just be the luck of the draw, but once you get a unit that is actually waterproof, it works quite well.

jky
__________________
jyasaki is offline   Reply With Quote
Old 27 April 2011, 16:22   #5
Member
 
Justribing's Avatar
 
Country: UK - England
Town: Devon
Boat name: Sweet Chariot
Make: Ribcraft 5.85m
Length: 5m +
Engine: Suzuki DF140
MMSI: 235065385
Join Date: Jun 2008
Posts: 45
I had this problem last year. Turned out that card reader was playing up took card out gave it a good clean, put it back together and it worked. Didn't make sense but its was ok after that!
__________________
Justribing is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:59.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.