Reply
 
Thread Tools Search this Thread
 
Old 08 March 2015, 12:33   #1
Member
 
Country: UK - England
Town: Dorset
Boat name: Seabadger
Make: Ribcraft
Length: 5m +
Engine: DF140
MMSI: -
Join Date: May 2010
Posts: 503
ICOM M423 VHF Failure

I installed a brand new ICOM M423 in May 2013. It failed on me yesterday. Was working fine when we left Poole but some point between Poole and Wareham it turned off and wont turn on again. Fuse was blown so I replaced that but still no success. Checked all wiring, it has 12 volts going in, anntenna connection secure, etc.

I'm glad I signed up for a 3 year warranty? What are ICOM like for things like this?
__________________

__________________
diver 1 is offline   Reply With Quote
Old 08 March 2015, 13:04   #2
Member
 
steco1958's Avatar
 
Country: UK - England
Town: West Bromwich
Boat name: Ellie V
Make: Excel Voyager 520
Length: 5m +
Engine: Evinrude 75 HP
MMSI: 235 908 287
Join Date: May 2012
Posts: 680
I have found them good with after sales questions on their facebook page.

I would suggest if they perform well on that type of medium then you will probably have a good experience with your particular issue
__________________
A bad day on the boat is better than the best day at work.
https://www.justgiving.com/RIOW2016
https://www.justgiving.com/Richard-Nash8
steco1958 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 22:49.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.