Thread Tools Search this Thread
Old 23 March 2015, 07:03   #1
Country: UK - England
Town: Poole
Boat name: Blue Ocean
Make: Ribeye 600
Length: 6m +
Engine: Yam 115
Join Date: Nov 2012
Posts: 139
Fish finder/Depth gauge problem

Hi all, I have a Lowrance X51 fishfinder/depth gauge attached to an external transducer. All from 2004.

A month ago all was working fine, but all of a sudden the screen will not display. The unit will turn on, I can hear it beep and clicks which I assume is the echo. however the screen looks like it is turned off.

I have checked the wiring and connections and all seem to be OK, but I am no electrician.

Any ideas before I think about a new unit?

Cheers, Andy

andyjcox1 is offline   Reply With Quote
Old 23 March 2015, 11:44   #2
boristhebold's Avatar
Country: UK - England
Length: 7m +
Join Date: Aug 2009
Posts: 1,280
On the surface the following may sound really dumb but I am serious it is worth checking as I had this experience with an older garmin plotter and depth guage unit.

Check the settings for brightness and contrast, on some units you can easily and not notice accidently adjust them so that the screen appears off when in fact its just the settings have changed.

So check those first, read your manual how to adjust screen settings contrast etc, if that is not the issue then screen may have given up. worth checking first.

boristhebold is offline   Reply With Quote
Old 25 March 2015, 10:23   #3
Country: USA
Town: Oakland CA
Length: 3m +
Join Date: Feb 2005
Posts: 6,621
What Boris said.

OTOH, I had an LMS332 (I think) on which the screen driver failed. I could just barely make out that the screen itself was drawing pictures, but it wouldn't light up (easier to see in the dark.) Lowrance had a flat rate repair price for out of warranty items, so they fixed it for something like $75 (don't know if they have that in the UK though.)


jyasaki is offline   Reply With Quote
Old 13 April 2015, 23:34   #4
Country: Canada
Town: Southern Ontario
Boat name: -Unknown-
Make: SeaMax
Length: 4m +
Engine: Merc/Minn Kota
Join Date: Mar 2012
Posts: 216
Check the manual for the location or method to reset the unit.
Nightfisher is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:36.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.