Reply
 
Thread Tools Search this Thread
 
Old 21 March 2016, 05:45   #1
Member
 
beerbelly's Avatar
 
Country: UK - England
Town: teesside
Make: valiant v570
Length: 5m +
Engine: mercury 100
MMSI: 232012453
Join Date: Apr 2014
Posts: 859
are my handhelds knackered

standard horizon hx370 hand helds x2 have been in a drawer in the garage since october but noticed the drawer full of mouse shit and bits of carwash sponge the radios smell of mouse piss . turn them on and they light up and seem ok but there doesn't seem to be any sound like there both muted or something tried on lots of different channels and nothing don't even get that crackle sound when you press the speak key .are they bin fodder or am I missing something. hope I'm missing something as new ones are expensive any help apreciated
__________________

__________________
beerbelly is offline   Reply With Quote
Old 21 March 2016, 06:07   #2
RIBnet admin team
 
willk's Avatar
 
Country: Ireland
Make: Redbay Boats
Length: 9m +
Engine: 370hp
Join Date: Feb 2008
Posts: 12,928
RIBase
Don't be offended by my basic suggestions:

Charge them up fully
Check volume is set max on both sets
Check Squelch is fully open on both sets (if electronic, check manual)
Check that they are set to International frequencies, not USA.
Test them against a known working VHF - if one handset is dud, they won't test out.

Mouse piss should be covered by IPX5/6
__________________

__________________
"Who knows what evil lurks in the hearts of men?"
.
willk is offline   Reply With Quote
Old 21 March 2016, 08:04   #3
RIBnet admin team
 
Poly's Avatar
 
Country: UK - Scotland
Boat name: imposter
Make: FunYak
Length: 3m +
Engine: 2 stroke YAM 20 HP
MMSI: 235089819
Join Date: Sep 2005
Posts: 10,114
Quote:
Originally Posted by willk View Post
Mouse piss should be covered by IPX5/6
You might want to give them a really good wash with warm water - just in case dried up Mouse Wee is sticking something...
__________________
Poly is offline   Reply With Quote
Old 21 March 2016, 08:29   #4
Member
 
Country: UK - England
Town: North Lincs
Boat name: Clam Chowder
Make: Humber
Length: 5m +
Engine: 85 Yam
Join Date: May 2010
Posts: 43
Get some IPA solvent PRO POWER - PPC103 - IPA SOLVENT, 400ML AEROSOL | CPC UK,
pull the volume knob off and spray the IPA down the shaft of the volume pot and turn about a bit to clean the tracks in the volume pot.
__________________
Boatintercoms is offline   Reply With Quote
Old 22 March 2016, 03:22   #5
Member
 
beerbelly's Avatar
 
Country: UK - England
Town: teesside
Make: valiant v570
Length: 5m +
Engine: mercury 100
MMSI: 232012453
Join Date: Apr 2014
Posts: 859
cheers folks ill give the suggestions a try although I have no manual for them and I'm not sure there is squelch adjustment. seems odd they both seem to have the same issue I will fully charge first as both are showing low charge when you key to speak
__________________
beerbelly is offline   Reply With Quote
Old 22 March 2016, 05:06   #6
RIBnet admin team
 
willk's Avatar
 
Country: Ireland
Make: Redbay Boats
Length: 9m +
Engine: 370hp
Join Date: Feb 2008
Posts: 12,928
RIBase
Quote:
Originally Posted by beerbelly View Post
cheers folks ill give the suggestions a try although I have no manual for them and I'm not sure there is squelch adjustment. seems odd they both seem to have the same issue I will fully charge first as both are showing low charge when you key to speak
Manual: Linky Squelch is set in software.

No charge is probably your issue - were you really going to bin them without charging them first?
__________________
"Who knows what evil lurks in the hearts of men?"
.
willk is offline   Reply With Quote
Old 22 March 2016, 05:14   #7
Member
 
beerbelly's Avatar
 
Country: UK - England
Town: teesside
Make: valiant v570
Length: 5m +
Engine: mercury 100
MMSI: 232012453
Join Date: Apr 2014
Posts: 859
You are absolutely bang on wilko (hangs my head in shame) both had very low battery and I looked online and found the user manual and adjusted the squelch and bingo the one with a bit more charge started receiving the weather update which I also didn't know I had . I just can't understand how the squelch got turned up so high as they both worked fine last October
__________________
beerbelly is offline   Reply With Quote
Old 22 March 2016, 05:15   #8
Member
 
beerbelly's Avatar
 
Country: UK - England
Town: teesside
Make: valiant v570
Length: 5m +
Engine: mercury 100
MMSI: 232012453
Join Date: Apr 2014
Posts: 859
Oh and thanks very much for the input everyone who replied.
__________________

__________________
beerbelly is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 13:10.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.