Reply
 
Thread Tools Search this Thread
 
Old 23 July 2012, 16:43   #1
Member
 
Country: UK - Channel Islands
Town: jersey
Boat name: Jeannie
Make: maxum
Length: 4m +
Engine: Tohatsu 90 2 stroke
Join Date: Jul 2012
Posts: 3
Tohatsu 90hp stuck in safe mode, not revving

Hi all,
We have a 90hp 2 stroke Tohatsu on a 18' Maxum Speedboat. It's been fine for the last 4 years but now after its last service the engine won't rev or go above 6 knots. We first thought the intake filters might have been blocked but it wasn't that. The engine passes the diagonstic tests, and we changed the cdu which had no effect.
Has anyone got any other sugggestions?
Thanks
__________________

__________________
jimmy24 is offline   Reply With Quote
Old 23 July 2012, 18:26   #2
DM
RIBnet supporter
 
Country: UK - England
Boat name: Little Wing
Make: Searider 5.4
Length: 5m +
Engine: Tohatsu 90
Join Date: Aug 2002
Posts: 1,067
Quote:
Originally Posted by jimmy24 View Post
Has anyone got any other sugggestions?s
There's a water pressure sensor micro switch on the port side of engine, high up, towards the rear. It can stick putting the engine into limp home mode. Giving it a flick with a stanley blade and a spray of lubricant usually solves the problem.

If the problem persists, you can isolate the switch but Tohatsu don't recommend it for obvious reasons.

It's also adjustable for sensitivity but if you start messing with it, it can take ages to get it right.
DM is offline   Reply With Quote
Old 24 July 2012, 00:31   #3
Member
 
Country: Finland
Town: Helsinki
Boat name: SR 5.4
Make: Avon
Length: 4m +
Engine: Toh1 3,5 Yam 90/2S
Join Date: Oct 2009
Posts: 896
Here might be something helping to diagnose the problem:
Strange wires from CD unit M90A

Disconnecting the wires most likely overrides all sensors(oil level, water pressure, water temp....) so You can check is it sensor related or not. But there is also a risks involved running it with safety features disconnected...
__________________
fun on a boat is inversely proportional to size...sort of anyway
C-NUMB is offline   Reply With Quote
Old 24 July 2012, 02:33   #4
Member
 
Country: UK - Scotland
Town: Glasgow
Boat name: snagglepuss
Make: Shetland
Length: 6m +
Engine: 90 hp Outboard
Join Date: Nov 2011
Posts: 562
it does sound like a sensor telling it to be in limp home mode but I would be tempted to take it to a local dealer as it should be them taking the risk if you turn off the sensor warnings and not you i.e. they are the experts.

if it was smaller I would say send it to us as we are a bit to far away for even our mobile service!

good luck
__________________
clydeoutboards is offline   Reply With Quote
Old 24 July 2012, 15:20   #5
Member
 
Country: UK - Channel Islands
Town: jersey
Boat name: Jeannie
Make: maxum
Length: 4m +
Engine: Tohatsu 90 2 stroke
Join Date: Jul 2012
Posts: 3
Thanks all for the comments, some good ideas there for me to try this weekend.
Cheers
__________________
jimmy24 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 13:07.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.