Thread Tools Search this Thread
Old 03 August 2007, 03:30   #1
Country: UK - Wales
Town: Anglesey
Join Date: Oct 2003
Posts: 8
suzuki 90 trim

I had some probs with the power trim unit on my 90hp 4 stroke suzuki 2001 model, took the trim unit off and stripped down, some corrosion inside, when I reassembled, ive seen water pools on top of the trim unit at the ram seel, and will not drain. This may be where water is getting in. Has anyone else seen this on a suzuki? Also, the engine is bolted with the top of the bracket 2" clear of the transom, is this normal? should I be putting a bit of ply in there, or just lower the engine? Its on a zodiac 550 btw.
EdGriffiths is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Member's RIBs




Add your RIB

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 14:53.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.