Reply
 
Thread Tools Search this Thread
 
Old 30 May 2014, 05:48   #1
Member
 
sovereignrach's Avatar
 
Join Date: Mar 2014
Posts: 12
Suzuki 70hp 4 Stroke no power over 3000rpm

Hi, took our rib out for a spin last night and once clear of the harbour I put the throttle on but there was no power. When the throttle was on full It would not rev to more than 3000rpm and hit 7 knots max. It idles fine and is ok at low speed. My boyfriend has checked the engine and everything appears to be as it should be. There are no engine lights or other warning signs. Has anyone else experienced this? Any ideas? Thanks.
__________________

__________________
sovereignrach is offline   Reply With Quote
Old 30 May 2014, 05:55   #2
Member
 
Country: Ireland
Town: Castlebar
Boat name: Clewless
Make: Valiant DR 490
Length: 4m +
Engine: 60 hp ETEC
MMSI: Awaitng one
Join Date: Oct 2007
Posts: 1,240
RIBase
Is the boat full of water under the deck?
__________________

__________________
two stroke mick is offline   Reply With Quote
Old 30 May 2014, 06:37   #3
Member
 
sovereignrach's Avatar
 
Join Date: Mar 2014
Posts: 12
It could be! How would I know? (very new to ribbing!) the auto bilge isn't working and due to the rain it has been filling up (although I've been emptying regularly)
__________________
sovereignrach is offline   Reply With Quote
Old 30 May 2014, 06:40   #4
Member
 
henryfreston's Avatar
 
Country: UK - England
Town: Thornbury
Make: Avon Searider 4m
Length: 4m +
Engine: 50hp tohatsu tldi
Join Date: Sep 2012
Posts: 648
know this sounds really simple, but i was out on my searider last weekend and I was bouncing around and I suddenly lost all power (similar symptoms, had no power and wouldn't rev above 3000 rpm etc.)

I took it in and found that one of the HT lead heads had come off the spark plug. I would double check yours even if they look in place as they could be lose?

Henry
__________________
henryfreston is offline   Reply With Quote
Old 30 May 2014, 06:41   #5
Member
 
henryfreston's Avatar
 
Country: UK - England
Town: Thornbury
Make: Avon Searider 4m
Length: 4m +
Engine: 50hp tohatsu tldi
Join Date: Sep 2012
Posts: 648
Quote:
Originally Posted by sovereignrach View Post
It could be! How would I know? (very new to ribbing!) the auto bilge isn't working and due to the rain it has been filling up (although I've been emptying regularly)
there should be a drain plug at the bottom of the transom (at the bottom of the V) You can screw this out and water will drain from inside the hull.
__________________
henryfreston is offline   Reply With Quote
Old 30 May 2014, 08:32   #6
Member
 
Country: UK - England
Make: ribcraft
Length: 4m +
Join Date: Jul 2011
Posts: 96
To check it's not the engine see if it revs normally in neutral while the boat is still?
__________________
gary222 is offline   Reply With Quote
Old 30 May 2014, 08:39   #7
Member
 
henryfreston's Avatar
 
Country: UK - England
Town: Thornbury
Make: Avon Searider 4m
Length: 4m +
Engine: 50hp tohatsu tldi
Join Date: Sep 2012
Posts: 648
Quote:
Originally Posted by gary222 View Post
To check it's not the engine see if it revs normally in neutral while the boat is still?
An engine can rev normally when in neutral, but when put under load can act completely different.
__________________
henryfreston is offline   Reply With Quote
Old 30 May 2014, 08:52   #8
Member
 
Country: UK - England
Town: Royal Wootton Bassett
Length: 8m +
Engine: 250
Join Date: Jul 2008
Posts: 8,020
Is it due a service and cut down on the revs, if so you can reset it. Worth a look
__________________
whisper is offline   Reply With Quote
Old 30 May 2014, 17:18   #9
Member
 
Country: UK - England
Make: ribcraft
Length: 4m +
Join Date: Jul 2011
Posts: 96
Quote:
Originally Posted by henryfreston View Post
An engine can rev normally when in neutral, but when put under load can act completely different.

yes but if it doesnt rev even in neutral then its likely engine related .
__________________
gary222 is offline   Reply With Quote
Old 30 May 2014, 17:22   #10
Member
 
Country: UK - England
Town: N. Devon
Boat name: Nutkin Too
Make: X-Pro Defender
Length: 5m +
Engine: Outboard, Suzuki 90
MMSI: 235095884
Join Date: Dec 2008
Posts: 1,367
RIBase
Suzuki engines have a safe / get you home mode. Chances are an engine service is needed as a plug will be down, carb gummed up etc,
__________________

__________________
Andy

Bude Dive Club - www.budediveclub.co.uk
GAFIRS - www.gafirs.org.uk
treerat is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:24.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.