Thread Tools Search this Thread
Old 30 May 2013, 14:55   #11
Boatnomad's Avatar
Country: Ireland
Make: Zodiac Mk I
Length: 3m +
Engine: 15 hp Yam two stroke
Join Date: Feb 2012
Posts: 728
Originally Posted by Wee Dafty View Post
I have found this before after a winter lay up from a season in salt water. If the engine is not flushed through properly then salt can crystalise in the pipework and it takes a bit of time to break down. All good after that though.
Little bit of wire in the telltail-outlet works a treat,

Boatnomad is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:27.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.