Reply
 
Thread Tools Search this Thread
 
Old 27 February 2012, 14:34   #1
Member
 
TomKat's Avatar
 
Country: Ireland
Town: Bangor
Boat name: Lencraft 4.8m
Make: Lencraft
Length: 4m +
Engine: DT55HP Suzuki
Join Date: Jul 2011
Posts: 469
Quicksilver control box kill switch

My recently acquired Mariner 75 has a quicksilver control box. The engine is not sparking so my first port of call is the kill switch. It is open circuit all the time, is this the kill mode?

If it is has anyone got a spare one? Mr Turbo Diesel can you help?

Cheers

TK
__________________

__________________
TomKat is offline   Reply With Quote
Old 28 February 2012, 06:55   #2
Member
 
TomKat's Avatar
 
Country: Ireland
Town: Bangor
Boat name: Lencraft 4.8m
Make: Lencraft
Length: 4m +
Engine: DT55HP Suzuki
Join Date: Jul 2011
Posts: 469
Have ordered a new kill switch so should be sorted.
__________________

__________________
TomKat is offline   Reply With Quote
Old 28 February 2012, 11:27   #3
Member
 
Country: USA
Town: Oakland CA
Length: 3m +
Join Date: Feb 2005
Posts: 6,653
Short it and try it. Only 2 conditions it can be in (assuming it's working.)

jky
__________________
jyasaki is offline   Reply With Quote
Old 28 February 2012, 14:18   #4
Member
 
TomKat's Avatar
 
Country: Ireland
Town: Bangor
Boat name: Lencraft 4.8m
Make: Lencraft
Length: 4m +
Engine: DT55HP Suzuki
Join Date: Jul 2011
Posts: 469
Quote:
Originally Posted by jyasaki View Post
Short it and try it. Only 2 conditions it can be in (assuming it's working.)

jky
should have tried that last night but ran out of time, new parts are ordered so will try it out when they arrive.

Cheers

TK
__________________
TomKat is offline   Reply With Quote
Old 28 February 2012, 16:38   #5
RIBnet admin team
 
Nos4r2's Avatar
 
Country: UK - England
Town: The wilds of Wiltshire
Boat name: WhiteNoise/Dominator
Make: Ballistic 7.8/SR5.4
Length: 7m +
Engine: Opti 225/Yam 85
MMSI: 235090687/235055163
Join Date: Jul 2005
Posts: 12,645
RIBase
Quote:
Originally Posted by TomKat View Post
It is open circuit all the time, is this the kill mode?
If it's a 2 stroke it should be sparking if there's no circuit.
__________________
Need spares,consoles,consumables,hire,training or even a new boat?

Please click HERE and HERE and support our Trade Members.

Join up as a Trade member or Supporter HERE
Nos4r2 is offline   Reply With Quote
Old 01 March 2012, 14:29   #6
Member
 
TomKat's Avatar
 
Country: Ireland
Town: Bangor
Boat name: Lencraft 4.8m
Make: Lencraft
Length: 4m +
Engine: DT55HP Suzuki
Join Date: Jul 2011
Posts: 469
Quote:
Originally Posted by Nos4r2 View Post
If it's a 2 stroke it should be sparking if there's no circuit.
you are quite right, the new switch did not fix the spark issue, new stator required.
__________________

__________________
TomKat is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:47.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.