Thread Tools Search this Thread
Old 01 June 2009, 03:08   #1
RIBnet supporter
Country: UK - England
Town: South Coast
Length: 7m +
Join Date: Apr 2008
Posts: 1,443
Optimax experts?

Last thing yesterday (Sunday), got an engine fault warning on the Smartcraft giving,
"Oil Level Sensor Fault - Input High"

Any thoughts as to what or how serious? Have phoned dealer who is trying to see if he can can find a replacement and then get the boat in, but am concerned that this may not take place before next weekend, when I was planning in taking part in the IOM run.

Thanks in advance
250kts is offline   Reply With Quote
Old 01 June 2009, 07:16   #2
Country: UK - England
Town: Dorset & Hants
Boat name: Streaker/Orange
Make: Avon/Ribcraft
Length: 4m +
Engine: 50Yam/25 Mariner
Join Date: Apr 2007
Posts: 5,551
Hi Steve - who have you approached ? RIBS marine in Christchurch have always been good to me with mine, but I'd guess if its just an oil tank sender issue so youd be OK to run without it being fixed as youre unlikely to burn tankfulls of oil without realising or seeing the level drop.

As a last resport if you cant get it looked at - have you tried pulling the plug on the sender ( at the tank) to see if it changes the warning ?


PeterM is offline   Reply With Quote
Old 01 June 2009, 13:05   #3
martini's Avatar
Country: UK - Channel Islands
Town: jersey
Boat name: Martini II
Make: Arctic 28/FC470
Length: 8m +
Engine: twin 225Opti/50hp 2t
MMSI: 235067688
Join Date: Jun 2005
Posts: 3,018
Almost guarenteed to be a short circuit in the tank sender unit. You could try disconnecting it but may read no oil then and you'll have alarms going off and driving you nuts!
martini is offline   Reply With Quote
Old 02 June 2009, 06:31   #4
RIBnet supporter
Country: UK - England
Town: South Coast
Length: 7m +
Join Date: Apr 2008
Posts: 1,443
Thanks for replies and PM's. Have now heard back from RIBS marine.

Apparently, my engine, the 115 Opti does not have this sensor, so the fault warning has probably always been there, just not noticed it before (i was ambling up the river and looking through all the pages of the smartcraft options when I found the warning). When in for the next service, they will reset the software to get rid of warning.

Thanks again
250kts is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:55.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.