Thread Tools Search this Thread
Old 27 January 2003, 06:33   #1
Country: UK - England
Make: Ribcraft 6.5
Length: 6m +
Engine: Suzuki DF175TG
Join Date: Apr 2002
Posts: 929
Mercury 60 FourStroke EFI - oil sump modification

I have just got my boat back from my local Mercury dealer after experiencing a very loud squeaking noise generated when the engines hot - very similar to that made by a slipping alternator belt on a car.

Anyway, Mercury say this has been happening on a small minority of their 60 F/ EFIs, apparently there is a tin plate between the power head and oil sump which resonates as the oil is sprayed onto it. They have a modified plate available to fit to engines with the above symptoms

Note:- It doesn't affect performance or damage the engine in anyway, so unless you engine is making the noise there is no need to worry.

DJL is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:58.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.