Reply
 
Thread Tools Search this Thread
 
Old 23 March 2012, 04:50   #11
Member
 
Country: UK - England
Town: Looe
Make: Delta
Length: 4m +
Engine: Mercury
Join Date: Apr 2004
Posts: 1,335
Glad all is working again!!
__________________

__________________
Black Dog Marine
www.blackdogmarine.com
Turbodiesel is offline   Reply With Quote
Old 19 April 2012, 09:16   #12
Member
 
Daibheid's Avatar
 
Country: Ireland
Town: Cork
Boat name: Excalibur
Make: Excalibur + Zapcat
Length: 6m +
Engine: Merc120TDI,Tohatsu50
Join Date: Jun 2005
Posts: 245
Quote:
Originally Posted by TomKat View Post
New red stator now fitted, as i am an idiot I wrecked the flywheel by using a gear puller, one magnet broke in half (presumably by flexing). Got another used flywheel off a 115HP engine, interestingly the starter ring had a larger OD so had to change the starter as well.

Would recommend it to be done by a dealer/marine mechanic as without the flywheel puller tool its impossible to get it off and without the flywheel holding tool its very hard to torque the flywheel back on properly.

Normal service has now been resumed! Thanks for all the advice chaps.
Glad you got there in the end and fair play for admitting what went wrong.
That's one of the strengths of RIBNET - people are willing to give others the benefit of painful learning experiences.
__________________

__________________
Daibheid is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 15:37.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.