Reply
 
Thread Tools Search this Thread
 
Old 29 June 2015, 02:52   #1
Member
 
Country: UK - England
Town: Worthing
Make: Avon
Length: 4m +
Join Date: Jun 2015
Posts: 1
Mariner 20hp water pump

I decided to sell this engine as I've spent almost 400 on it this year. When I went to change the impellor I noticed the last person to change it had almost snapped the rubber grommet that connects the water tube to the top of the water pump housing. Rather than replace the couple of quid grommet they decided to bodge it together with glue/mastic. Seeing as I'm not spending another penny on it I put it all back together.
When I started the engine up the water was coming out of the top of the engine casing and not the water pipe.
My question is, Is there another rubber grommet that joins the water tube from the pump to the top of the engine. I've tried refitting the leg 6 times but the water is still coming out of the wrong place. Any ideas please ?
Attached Thumbnails
Click image for larger version

Name:	whater pump.jpg
Views:	62
Size:	128.3 KB
ID:	106461  
__________________
captainstew is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 21:50.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.