Reply
 
Thread Tools Search this Thread
 
Old 18 July 2019, 05:52   #1
Member
 
Wightdiver's Avatar
 
Country: UK - England
Town: Fareham
Boat name: Red Dog
Make: Porters Renegade
Length: 6m +
Engine: 150 HP Yamaha
Join Date: May 2010
Posts: 513
Hydraulics advice needed

Hi Guys, I need some advice on the hydraulic tilt and trim on my Yamaha 150 HPDI. I have noticed over the last 12 months that if the boat is not used for some time when I try to lift the engine (it sits on a trailer with the engine down) I need to hold the up button for a while before it starts to move.

Last weekend after not using the boat for almost 2 months it would not move at all. Kept trying and after 8-10, 10 second bursts it moved. Once it started I moved it up and down a dozen times easily with no delay at all.

Not an expert here but I am hoping that it might be just low oil level? So first question is how do I check? I am guessing it is something to do with the item in the second picture? Do I just unscrew it and see what’s there? Do I need to chock the engine or do anything else before diving in?

Any ideas or advice welcome.

Thanks
Andy
Attached Images
  
__________________
Wightdiver is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 19:52.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×