Thread Tools Search this Thread
Old 05 May 2014, 13:11   #1
Country: UK - England
Town: portsmouth
Boat name: patch
Make: avon sr5.4/4m
Length: 5m +
Engine: mercury 90/honda 30
Join Date: Oct 2008
Posts: 248
Honda bf30 2006 no power

Hi all I have the above on my 4m avon it's been on there since new and used to have so much power but last year I managed with it but it was loosing off the mark power but I put it away for the winter and today I put a fresh tank of fuel in her pumped the bulb and she started straight up but it's lumpy on idle and would not get up on the plane, any ideas would be great !!!!
tim2658 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:26.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.