Thread Tools Search this Thread
Old 22 May 2016, 13:16   #11
Country: UK - Scotland
Town: Tiree
Boat name: Silver Wing
Make: RedBay Storm force
Length: 6m +
Engine: Inboard diesel
Join Date: Sep 2015
Posts: 6
The sea conditions don't appear to make any difference to the alarm, I've been out in various sea conditions and all is ok, its just when you give her that extra few revs that the alarm sounds. But it would be good to get to the root cause. Thanks

Donnie macinnes is offline   Reply With Quote
Old 23 May 2016, 15:13   #12
RIBnet supporter
Erin's Avatar
Country: UK - Channel Islands
Town: A large rock
Boat name: La Frette
Make: Osprey Vipermax
Length: 6m +
Engine: 200 Suzzy
Join Date: May 2004
Posts: 2,797
Presumably the impeller casing has been checked for wear. I would be tempted to try a back flush on the block just in case there's debris stuck somewhere.
Erin is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 18:31.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.