Thread Tools Search this Thread
Old 28 August 2007, 03:22   #1
Country: UK - England
Town: Mudeford
Make: Humber Ocean Pro 5.3
Length: 5m +
Engine: 90ho Tohatsu
Join Date: Apr 2005
Posts: 137
clicking sound from engine tilt....


when tilting my engine down, just before i get to the slow trim stage i get some quite loud clicking / knocking sounds, the the slow trim starts and all sounds fine again. It sounds a bit like a cog slipping, that's the best description i can give.....

Tohatsu 90 TLDI.......

Any ideas?

psychopic is offline   Reply With Quote
Old 28 August 2007, 10:24   #2
Country: USA
Town: boston
Boat name: Miss bad 61
Make: Crapko, AKA Mako
Length: 5m +
Engine: OMC Mod50
Join Date: Apr 2006
Posts: 398
shoot some grease in to tilt toob fitins, check the upper and lower pins and bushins of the center ram. that is ware i would start.
fast fred is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:05.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.